Hobie Cat Forums

It is currently Fri Nov 28, 2014 6:53 am

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sat Feb 26, 2011 3:56 am 
Offline
Site Rank - Deck Hand

Joined: Tue Feb 15, 2011 2:29 am
Posts: 4
I bought a cheap Hobie 14 Turbo last week and took it for a sail today. Everything went well except that the jib was constantly luffing at the leach in any sort of gust. Even when the tell-tales on the mainsail and the lower tell-tale on the jib were lining up perfectly, the top half of the jib was flapping like crazy. The jib has a sailmakers logo from the Central Coast (Australia) so I'm wondering if the sail has been poorly made or is not a Hobie 14 jib at all. I have a Hobie 16 as well and even without battens the jib works perfectly. I'm thinking about trying the Hobie 16 jib on the H14 Turbo tomorrow. Every other aspect of the H14 Turbo seems to be consistent with the upgrade kits I've looked at online.

So I guess I have two questions. Does anyone know what might be the cause of my jib problems... and is it possible to sail a H14 turbo with a Hobie 16 jib?

Cheers and thanks in advance...

Brendan


Top
 Profile  
 
PostPosted: Sat Feb 26, 2011 2:23 pm 
Offline
Hobie Approved Guru

Joined: Mon Jul 14, 2003 7:11 pm
Posts: 4623
Location: Detroit, MI
1) The jib is blown out. Either get used to it or get a new one.

2) a 16's jib is far too large for the 14. You won't be able to hoist it all the way.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group