Hobie Cat Forums

It is currently Tue Jul 29, 2014 11:03 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Sun May 02, 2010 3:17 pm 
Offline
Site Rank - Captain

Joined: Mon Jul 24, 2006 4:52 pm
Posts: 120
Location: South Florida (Coral Springs)
After the third use of my Tandem Island I now have a creaking sound whenever I turn my rudder control handle. I assume the handles on both the single and tandem islands are all the same. So my question is, looking at the picture below, is this how the spring is supposed to be set below the handle? Using a mirror, I was able to see that when I moved the handle, two pieces of the spring were rubbing together making the noise. The spring on both rudder control handles appears to be set the same, so I'm curious how this creaking noise started if nothing moved out of place, unless both springs readjusted themselves on the same trip. Both handles are making the noise, but the front is a little louder. Has anyone has had this occur, or know the proper setting of the spring? If there were something that could be done to correct this, I'm not sure how you'd get to it. I'm sure the rudder handle pops off somehow, but I didn't want to break something else trying when this is just an annoyance now.
Image


Top
 Profile  
 
PostPosted: Sun May 02, 2010 4:14 pm 
Offline
Site Rank - Old Salt

Joined: Fri Jan 05, 2007 9:21 pm
Posts: 2226
Location: Maui, Hawaii
I had a similar problem on one AI and I was able to rotate the spring by hand about 180 degrees, without having to remove the handle, and the squeak went away. Maybe it will work for you?

_________________
Image
http://KayakingBob.com - - - - - Hobie Island Sailing since 2006 - - - - - 2011 & 2012 Hobie AIs and a 2012 TI


Top
 Profile  
 
PostPosted: Sun May 02, 2010 10:56 pm 
Offline
Hobie Approved Guru

Joined: Sat Nov 12, 2005 10:46 pm
Posts: 2388
Location: Escondido
Shot of silicone spray? 8)


Top
 Profile  
 
PostPosted: Mon May 03, 2010 12:40 pm 
Offline
Site Rank - Captain

Joined: Wed Oct 21, 2009 8:40 am
Posts: 29
Location: Belgium (Flanders)
I gave it a shot on our Oasis, and it worked, just as Roadrunner sais :)


Top
 Profile  
 
PostPosted: Sun May 23, 2010 7:44 am 
Offline
Site Rank - Captain

Joined: Mon Jul 24, 2006 4:52 pm
Posts: 120
Location: South Florida (Coral Springs)
I tried the silicone spray and it seemed to work a little, but there's still some noise. It's very difficult to spray the stuff in the right place since you can't really see what you're doing. I did give it a pretty good dose and stuck my hand up there and tried to work it between the area where the spring was rubbing. I tried rotating the spring a little too as suggested, but this was very difficult since I tried doing this after spraying the silicone spray (too slippery).


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group